Can't start the dedicated steam server anymore

  • Welp apparently the storage engine crashes and the whole thing just shuts down without a word.
    Could other people please verify this?

    Because it could my PC too but since I completely wiped all screeps related data for a fresh install I doubt it.

    I'll try to switch the dedi to Redis/MongoDB in the meantime maybe I'm lucky and it works.

    Isn't it always so? You'll get a nice idea want to test it and something completely unrelated just spoils the effort 😑

  • You mention that you "completely wiped all screeps related data", but can you double check that deleting the "Steam\steamapps\common\Screeps\server\db.json" file doesn't resolve your problems?


  • Dev Team

    Can someone confirm it?

  • @QzarSTB Dude when I say everything, I mean everything down to registry residue. (MS 🙄)
    And it still doesn't work, just checked again.

    I build the git version and it runs fine... so there is at least that.

  • I had similar problems in the past solved by deleting the folder C:\Users\nnnn\AppData\Local\Screeps\User Data

  • @Geir1983 didn't solve my problem so...

    Was anybody able to reproduce it yet?
    WTF is wrong with my machine 😑 or rather steam install... or both?

    I'll mark it as solved for now, since it seems to be on my end.
    Perhaps it is unrelated with the update, as long i can run the git version everything is fine.