Client crashes on keyboard input (linux)



  • Typing on my keyboard while in game crashes the client on Linux. Running on proton is even worse - the client doesn't even open.

    I have tried restarting, reinstalling, and moving the game to a different disk. None of these have worked.

    This wouldn't normally be an issue as I play on the browser version but I've been wanting to test out a private server, and that's near impossible without the steam client.

    Debug logs:

    0_1569550151300_2bd8e012-378e-4e12-9a3d-a29b607f86f9-image.png 0_1569550174800_a4d5e666-3d39-4c85-a06c-e6346c09860a-image.png


  • Dev Team

    @godman180 which Linux is this?


  • Culture

    I'm having this issue with an uptodate Arch Linux install. I get the error: (nw:1310757): Pango-ERROR **: 15:24:53.582: Harfbuzz version too old (1.4.2)

    It appears that newer pango versions have broken it, Plexamp has the same issue: https://forums.plex.tv/t/plexamp-linux-crash-on-launch/444951/38

    The current fix seems to be downgrade pango (Not ideal IMO as it breaks other apps like Thunar)



  • @o4kapuk Arch Linux



  • Downgrading pango worked. Here is the command I used:

    sudo pacman -U https://archive.archlinux.org/packages/p/pango/pango-1%3A1.44.1-1-x86_64.pkg.tar.xz



  • @godman180 said in Client crashes on keyboard input (linux):

    Downgrading pango worked. Here is the command I used:

    sudo pacman -U https://archive.archlinux.org/packages/p/pango/pango-1%3A1.44.1-1-x86_64.pkg.tar.xz

    Thank you. I'm having this problem for months already. I receive different error thogh. Downgrading pango indeed worked.. Let's hope this don't break anything else



  • Hi there. I'm just here to say that I have the same problem (I use Manjaro Linux with pango 1:1.44.5-1 from the Manjaro extra repository).

    I'm completely new to this game/sim (own it since today), so I'm grateful this thread mentioned the browser version, which I was previously unaware of - the browser version works for me.

    That being said, I still hope you fix the steam client version.



  • I note that this has been marked "Solved", yet it is still an issue (e.g. to anyone finding their new system install makes Screeps crash raises hand).

    What has been found is merely a workaround, not a solution - especially if that workaround breaks other things (@ags131 notes that it affects Thunar - something that is perhaps more important to have working than keyboard input in Screeps!).

    The latest version with which the Steam client works is 1.44.1, as @godman180 noticed. (1.44.1 has a date of 27-Jul-2019 in the arch repository.) I did check that no version later than 1.44.1 (up to the most recent one - 1.44.7 25-Oct-2019) works; I also tried using different versions of harfbuzz (as that sounded like it might be the specific cause, rather than pango itself), but the client won't start with any version below 2.6.0, and crashes on input with that version.

    Please reopen this, and only mark it as solved when the client no longer crashes with the newer versions of pango. Even if this is an issue with proton (which something tells me it might be).


  • Dev Team

    We don't treat forum posts as support tickets, "Solved" status here doesn't mean anything for the Screeps Team, it's mostly for forum visitors to see if the issue has been resolved with some immediate solution.

    We already scheduled NW.js upgrade in the nearest future which will prevent this from happening.

    ♥