Steam client Chromium update

  • Dev Team

    The Steam client is updated from Chromium 59 to a newer Chromium 76 (NW.js version 0.40.2) for better client performance and bug fixes. This build is still beta, you can activate it using the new-chromium beta branch in Steam:


    Please let us know how it works for you in the comments below. We will promote it to default in a while if no issues arise.


  • Is a access code required?


    I have only one item in the drop down: "None - Opt out of all beta programs"

    Nothing happens when I select the drop down menu "Select the beta you would like to opt into:"

  • Dev Team

    @nrnoble Access code is not required. You may try to restart your Steam client or reinstall Screeps.

  • @nrnoble There is a global steam setting for opting into betas-

  • Dev Team

    @tron This is for the Steam client betas itself, not for games betas.

  • This new chromium apparently fix font rendering bug on linux.

  • This post is deleted!

  • After messing with the 'minimize console' button, im unable to keep the console window 'open', it keeps setting its state to minimized any time it should become present (changing from world view to room view)

    This is occuring on Windows 10 19033.

    Edit: it appears you cant move the console to a new window either.

  • @artch The update has fixed the Linux crash when typing anything on the keyboard and fixes some of the broken fonts! I'll continue to use this version until it's pushed to upstream, thanks for the beta!

  • Dev Team

    @mazdur I couldn't reproduce this issue, can you provide more details?

  • I also had the same issue as @MaZDuR where I have to "drag" the console window up after having minimised it.

    But more importantly, i'm getting the following error when trying to connect to a private server, restarting did not help when I tried the beta. 0_1576860945274_d12894d9-192c-49cd-9535-b3d29a9b4c7b-image.png

    It looks like this update has been pushed to live as well now, so I can't connect to any private server now with the official client

  • Dev Team

    @thmsn Did you try to restart Steam client, not the game client?

  • @artch Yes I restarted steam, as well as the game client, during the beta client, also just tried it with the official client. still can't connect to a private server, not my local one, nor the SWC one 🙂

    Now when I tried the beta, it worked for a while, untill it broke like this, then I swapped back to the official release instead of the beta, the game just updated now, and i'm stuck on this screen for private servers, I can connect to official fine.

  • Dev Team

    @thmsn Since I cannot reproduce this issue, I need some help to nail it down. Could you please do the following:

    1. Download this
    2. Extract it to your Steam game client folder (something like C:\Program Files (x86)\Steam\steamapps\common\Screeps) replacing existing files.
    3. Launch and open developer console (F12 or Ctrl+Shift+I).
    4. Reproduce the error and check the console output.

  • @artch Sure thing 0_1576863767873_4e865d42-67d9-4bde-9a57-3bc7127574e9-image.png

    angular.js?bust=1575144829168":1 Error: Failed to execute 'setItem' on 'Storage': Setting the value of 'local:auth' exceeded the quota. at Object.s.put (build.min.js?bust=1575144829168:1) at Object.t.set (build.min.js?bust=1575144829168:1) at build.min.js?bust=1575144829168:1 at angular.js?bust=1575144829168":1 at angular.js?bust=1575144829168":1 at l.$eval (angular.js?bust=1575144829168":1) at l.$digest (angular.js?bust=1575144829168":1) at l.$apply (angular.js?bust=1575144829168":1) at angular.js?bust=1575144829168":1 at C (angular.js?bust=1575144829168":1)

  • Dev Team

    @thmsn This looks very strange. Please try to make a full clean reinstall of the game:

    1. Uninstall it from Steam.
    2. Remove the Steam game folder C:\Program Files (x86)\Steam\steamapps\common\Screeps.
    3. IMPORTANT: Remove the folder %LocalAppData%\Screeps (like C:\Users\<username>\AppData\Local\Screeps).
    4. Install it again.

  • @artch said in Steam client Chromium update:


    Well, doing thoose steps, fixed it 🙂 guess we will never know what was wrong xD.

  • Dev Team

    @thmsn I believe you connected to so many different private servers that have exceeded localStorage capacity for auth credentials in Chromium somehow, and the new Chromium may have lower capacity, we need to research that.

  • @artch I've been swapping between a few private servers, but it's been below 10 servers or something I think? - but yeah, more research is needed 🙂

  • If you need somebody else for debugging, I have the same problem.

  • Dev Team

    @duckymirror It would be interesting to check the local storage. If you install the nwjs-sdk version using the link above, it can be accessed as usual from the Developer Console / Application / Local Storage. Try to identify whether there are some items that seem too big and may exceed the allowed capacity.