Favourited private server not connecting

  • I created a private server to try out the game for myself, with which I encountered the following bug:

    1. Set up a private server favourite
    2. Close the client and restart it.
    3. Attempt to reconnect using the favourite. It will attempt to connect for a while, then say it couldn't connect.
    4. Entering the contact details manually works perfectly fine.

    I've tried this multiple times, same thing happens every time. Server sees no issues.

  • Uhm how did you setup the server?
    Local or dedicated?

  • It's a dedicated server hosted in a hosting company's data center somewhere. I've configured the firewall to let port 21025 pass TCP and UDP traffic (default port for Screeps afaik). As mentioned, I am able to connect to the server, so I assume the issue isn't in the firewall.

  • Are you using a direct IP or a DNS/URI address?
    Have you tried to flush your DNS Cache?

  • Dev Team

    I wasn't able to reproduce the issue using the steps provided. Is the server you're experiencing issues with publicly available?