Re: [Visual bug (Broken lighting and rotating yellow planes)]

  • Re: Visual bug (Broken lighting and rotating yellow planes)

    • Which shard is affected?

      Shard3 (Re: Shard3|Private server|"someone else on Slack also reported that it has happened to him in the browser")

    • What should have happened?

      Re: "Normal lighting behavior and no rotating yellow planes"

    • How can we reproduce this? / What happened?

      I'm using the Steam version. unsuccessfully tried to replicate in the browser.

      This happens sometimes when I try to change which room I view (Both arrows, and map)

      Every room with turrets has this visual bug when it first happens, and the center of the rotating yellow planes is the turret. The speed of the rotation seems to be the same as the rotation speed of the turret. A weird overlap happens with multiple turrets, sometimes covering the whole room in yellow.

    • The only thing that can fix it so far, is an application restart.

    alt text

    Overlap example:

    alt text alt text

  • @o4kapuk wasn't that fixed a long time ago?

  • Dev Team

    @mrfaul I believe it was.

    @Z3R0 please try clearing "User data" in the screeps app folder and let us know if the issue appears after that.

  • @o4kapuk Ok, done. It usually happens a few times a day if I'm active, and never before a few hours have passed after each reset. I will let you know if it happens again.


  • @o4kapuk Well, it happened again. but this time I noticed something else too.

    I was building the rampart, and I could see its "stats" when it was a construction site, but as soon as it was built (1hp rampart) I couldn't see it anymore (example picture below. cause it's similar, but during this visual bug I can't see any object stats), but only that rampart that where bugged (every other object worked as normal) Therefore I changed rooms, and took that picture to verify.

    so my guess; the reason why the bug happens when you change rooms is cause you update everything. but the bug trigger is something else. since I just updated a "construction_rapart" to a "structure_rampart", and a part of that bug is hiding stats.

    alt text

  • @o4kapuk Tick # 5791411, if it helps (its the exact moment that rampart was built)

    Note: this is what i mean with stats: alt text

  • Are you running on WebGL or legacy?
    What are your settings?
    What is your OS?

    Cache should be in these folders:
    Windows: C:\Users<user>\AppData\Roaming\Screeps\Cache

    Linux: /home//.config/Screeps/Cache

    OS X: /Users//Library/Application Support/Screeps/Cache

  • @mrfaul Windows 10 (the picture shows settings and WebGL)

    About cache; I cant see any Screeps folders in "Roaming", but I do find a few folders named cache in Local\Screeps\User Data\

    (User Data\ShaderCache\GPUCache && User Data\Default\"multiple cache folders" (including a folder named just Cache; User Data\Default\Cache))

    alt text

  • Dev Team

    @z3r0 Weird, I still can't reproduce the issue on the replay you provided. We'll take a closer look at renderer. If you'll able to replicate the issue (which means the description of how to see it without words like "sometimes"), that would help a lot!

  • @o4kapuk I am not able to reproduce it in the world replay either, and for now I only know that the trigger is time/random based (I dont think its something with the world, rather the game. maybe a full reinstall might fix it, but we still wont understand what the issue is) Is there anything in the game code that activates after a certain amount of time? around 3h? cause it has never happened back to back, its always more than 2-3 hours between them.

    bad data package? corrupt file? maybe that information can be gathered by cache/logs? if so, maybe the Tick can help find the time?

    Tell me if you want me to reinstall, and I can take out my scripts.

  • @o4kapuk If I remember correctly the last time that occurred it was also visible in the replay...
    @Z3R0 have you tried to switch to legacy?
    If it happen there it could be a hint that it isn't the renderer rather something underlying where it gets is informations from.
    Also please update your driver's it is unlikely but sometimes a solution.

  • @mrfaul I can try.


    about the bug and objects in the room. I can read the stats of Creeps, room controller, sources, spawns. But I can't read static things, like roads, walls, ramparts, and minerals (without extractor)

    Also, I can't click on settings (Display options), and if I click "view profile" I get this error/picture (repeatable "Edit: repeatable before reset")

    alt text

    The reason I apply "sometimes", is cause I can be away from my computer a few hours get back and refresh everything (by changing room) and the bug is there, or play actively and the same happens.

  • Legacy/(WebGL turned off)

    alt text

    Was able to see my profile, and click settings now. not sure if it's related at all, but I'm leaving it in. Also, I'm able to see some of the object stats I could not see last time (including rampart)

  • @o4kapuk Are SVGs used for the renderer?
    If so, it might be a faulty path, easiest test would be to run all through a validator like the one W3C offers.

  • Dev Team

  • @o4kapuk not sure how many or who have this issue. but I know of one more who have more or less the same scenario as me.

    • Steam

    • Played the game a while back, and just started to play again. (just updated the game, so not a fresh install as far as I know)

    I will try to reinstall the game, only keeping my scripts.

    • Copied "scripts" in AppData local screeps
    • Uninstalled via steam
    • removed screeps folder in appdata local
    • removed screeps folder in steam
    • install, and adding my scripts

    Edit: Did not solve the issue.

  • I wanted to report that I have exactly the same issue on Steam version on Windows present in all available rendering settings. It happens randomly, often within ~1h of play. I installed Screeps on 2019-04-30.

  • Same issue here.
    Seems to ocurr in the steam version only.
    WebGL on/off seems to make no difference.
    Switchting rooms triggers it, but i'm not sure what other conditions have to be met for it to appear.