WebGL optimization

  • Dev Team

    Short update: we've just deployed a patch to our WebGL renderer that drastically optimizes performance when the game window is zoomed in.

  • Room visuals are broken (nothing rendered). Update: When disabling room visuals in display options shortly and then enabling them again they do show. Until you switch room then they are gone again.

  • Dev Team

    @tun9an0 Thanks, fixed.

  • @artch The room visuals shows now -after- I zoom not on first render (when I switch rooms or turn on the visual through console)

  • Dev Team

    @tun9an0 It shows after the first tick, it's the same behavior as before. Zooming should not have anything to do with this.

  • The visuals are back, but the underlying screen is extremely dark. Note that (As explained in the now locked help topic.) that I'm not running the acceleration, as it's not available on the options dialog. I realize this makes me an edge case, and was fine with the less than stellar render performance. 0_1553610742302_e63aab16-a37f-448e-863d-75bf668e7870-image.png

  • Dev Team

    @smokeman This is interesting, I cannot reproduce it regardless of display and system settings. What's your GPU, OS and browser version?

  • AMD Radeon X1950 Windows 7

    Not using a browser, using the Steam Client. If I WAS using the browser, it would be Firefox. I know this is an ancient video card... and I assume that's issue. The "Use acceleration" checkbox is not available, as well as the Lighting and Swamp Texture checkboxes.

  • Dev Team

    @smokeman I still can't reproduce this even with hardware acceleration disabled (in both game display settings and globally in the system). One thing that you can do to help debug this, is to use Developer Tools in Chrome/Firefox and track what particular overlay element is causing this (by selecting each element on top of the room view and deleting them one by one).

  • I switched from the Steam Client to the browser. That works just fine. Whatever overlay that is causing this works in the Firefox browser, but not the Steam Client.

    If there are dev tools in the Steam Client, I don't know where they are (Assuming the thing even runs on a platform that supports that.)

  • There is one thing that is not like the others... the Exit Tiles. They look quite different. I don't generally use the browser for screeps, but I assume they are supposed to look like they did before. 0_1553613965499_a4b96e52-729b-47f6-87f3-4aa098b88936-image.png

  • @artch Yes, sorry, you are right. It was taking 2 ticks for the render to show up, drew conclusion too quickly. It's very responsive here, nice!

  • If I run the Steam Client, then reduce the window size and zoom in all the way, the screen will show as properly bright on the right hand side.


  • Dev Team

    @smokeman You can access Developer Tools in Steam client too. Here is how:

    1. Download and unzip this archive.
    2. Copy package.nw file from your Steam installation (SteamLibrary\steamapps\common\Screeps) to the unpacked folder.
    3. Launch nw.exe and press F12 to open dev tools.

  • @smokeman The exit tile problem is older than this update and is only present without hardware accaleration. (Firefox here too)

  • I can repeatably get it to turn on and off by displaying a single GUI element: The Power Creep power cooldowns. With the cooldowns off screen: 0_1553706406726_pc_off.PNG

    Then if I scroll the right pane up to expose the Power Creep's cooldown display: 0_1553706482657_pc_on.PNG

    It will do it every time.

  • Am I missing something or has the SVG renderer been removed?

    I often use the simulation and it runs a lot slower with the WebGL one (about factor 6).

  • @duckymirror Looks like I've been missing something... Turning off hardware accelaration gets legacy renderer speed back.