New improved WebGL renderer


  • Dev Team

    Deployed hotfixes:

    • Fixed broken tower animation
    • Fixed incorrect rotation of some creeps names
    • Fixed broken creep self-heal animation
    • Improved performance by caching GPU info

    Known issues: See the top post.



  • The longer my miner mines, the further he gets over the source. I use the steam client if it matters. 0_1508530017238_nw_2017-10-20_16-05-56.png


  • Culture

    Mine keeps getting frozen after what seems like a random amount of ticks. Doesn't matter if I am actively viewing the window or not.


  • Dev Team

    @hernanduer Check console errors please. Also, it probably can be reproduced in a replay on the same tick, it would help.


  • Culture

    @artch Haha, sorry.

    Here's a couple. Each one caused the page to freeze until reload.

    0_1508531117793_6280e846-3341-4e1f-a972-55d20cf96ec7-image.png


  • Culture

    Also, I know you guys recommend Chrome but I'd really like to use Firefox instead and with this upgrade it looks like that's a lot more viable. Except! It seems like using the scroll wheel to zoom in/out is broken in Firefox. This applies to both world and room view, so I'm guessing there's some issue attaching to that hardware event?


  • Dev Team

    @hernanduer

    Here's a couple. Each one caused the page to freeze until reload.

    Do you have room and tick number to reproduce this?


  • Dev Team

    @hernanduer

    It seems like using the scroll wheel to zoom in/out is broken in Firefox. This applies to both world and room view, so I'm guessing there's some issue attaching to that hardware event?

    Yes, indeed. It's not related to WebGL though, but we'll add this to our backlog.


  • Culture

    @artch Looks like it might be related to turret healing. I was having a difficult time replicating and was trying to remember what was going on. Pretty sure some creeps were getting attacked by invaders and then healed back in the home room, so I had a turret attack a creep and voila!

    s1/W5S7 0_1508532717196_595cd202-f02e-4950-b46f-4552c411b525-image.png


  • Dev Team

    @hernanduer Should be fixed now.


  • Dev Team

    @thaelina Please update and try to reproduce this again.


  • Culture

    @artch Well it doesn't break now, but healing beams from turrets are invisible.


  • Dev Team

    @hernanduer Indeed. Fixed.



  • On Linux, using the Steam client, it has horrible performance, listing WebGL as not supported. It works great in Chromium, but I can't play on private servers from the browser client.

    Screenshot

    Relevant info:

    • Distro: Arch
    • Kernel: 4.12.10-2-zen
    • Mesa: 17.2.2-1
    • xf86-video-amdgpu: 1.4.0-1
    • GPU: AMD R9 390

  • Culture

    In history mode, the observer animation loops very quickly whether history is playing or not.



  • 0_1508584624917_e6981524-08c7-4d25-a568-b515b772184a-image.png

    Nuker seems to be offset to much, it looks to be placed in the pos below where it actually is, to me atleast. The rampart in the picture shows the actual position, but if you try to click the base of the nuker, you will select the wrong pos.

    Edit: for reference, this is without the new graphics:

    0_1508585210180_a0c2c836-5afc-40b6-bbc8-0793112febbd-image.png



  • Got some weird rendering when tabbing back into the client. Zoomed out just to take a screenshot.

    0_1508589660742_3228c243-1a46-45d0-9fa1-da2e8cede774-image.png

    0_1508589500229_b883da8a-692e-4191-8c51-d009bbf2d980-image.png

    0_1508589610932_c55a39b1-11db-46e9-ae6d-49c03a0179c7-image.png


  • Culture

    I'm noticing some extreme slowdown when I zoom in to the closest couple of zoom levels.

    Zoomed out I get easy 60+fps but zoomed in it's down to 27-33. Nothing I can tell that's causing it except maybe swamp particles.



  • Just for your awareness: Just now I've had a bug where a big dark circle with a broad white-greyish border filled about 3/4 of the room, slightly offset to the top left of the center.

    Sadly I didn't take a screenshot or try to analyze it but I'll get back to this if it occurs again.

    UPDATE: It appears to be the spawn growing in size. It happened while I had windows locked but I am not sure if there is any connection to that. If I turn of WebGL renderer and turn it back on it resets back to normal.

    0_1508600721583_webGL_renderingError.PNG

    ~ 1 minute later 0_1508600799384_webGL_renderingError2.PNG


  • Dev Team

    Deployed fixes:

    • Fixed incorrect positioning of creeps when switching tabs (needs testing, please report if it happens to you again after this update).
    • Fixed growing spawn animation.
    • Small graphics changes.

    When you report a bug, please check the Known Issues list in the top post before to make sure it is not reported yet.


Log in to reply
 

Looks like your connection to Screeps Forum was lost, please wait while we try to reconnect.