Steam PTR build missing CLI?

  • When updating to the PTR build in the steam client on Windows 10 the CLI is missing. Reverting to the actual version and the CLI is again available. I also tested to disable all mods and have the same issue whenever the ptr build is active. The server runs as normal and executes the scripts ingame. As far as i can tell only the CLI is missing.

    The CLI interface shows a black screen, also the list of processes is missing:


    Backend.log:Loading mods from "F:\STEAM\steamapps\common\Screeps\server\modsy.json"

    • F:\STEAM\steamapps\common\Screeps\server\node_modules\screepsmod-mongo\index.js
    • F:\STEAM\steamapps\common\Screeps\server\node_modules\screepsmod-tickrate\index.js
    • F:\STEAM\steamapps\common\Screeps\server\node_modules\screepsmod-welcome\welcome-text.js the options [uri] is not supported Starting CLI server STEAM_KEY environment variable is not found, trying to connect to local Steam client Starting game server (protocol version 13) SockJS v0.3.18 bound to "/socket" Game server listening on CLI listening on localhost:21026 Running cronjob 'sendNotifications' Running cronjob 'roomsForceUpdate' Running cronjob 'genPowerBanks' Running cronjob 'genInvaders' Running cronjob 'purgeTransactions' Running cronjob 'recreateNpcOrders' Running cronjob 'calcMarketStats' Running cronjob 'deletePowerCreeps' Running cronjob 'roomsForceUpdate'

  • I noticed this as well when trying to test power, you can always disable ptr, add power to the account and then re-enable ptr


  • @slowmotionghost where you able to spawn in a power creep after trying that? I tried to add power to my account like you suggested and have created a powerCreep, but when calling the .spawn method i dont get an error code (returns 0), but also no powerCreep is spawned in. At this point im starting to suspect something is wrong with this build?

  • @geir1983 I haven't got an RCL 8 yet, i'll let you know if I can but sounds like it has problems for sure

  • @geir1983 I was actually able to spawn one, not sure what the problem with your case is 😕

  • Ok, thanks for confirming. I have no clue why it wont spawn, I tried both from code and from console. Only thing i could think of that could block it is if another powerCreep standing on the powerSpawn, but there is none spawned. However i have never spawned in one so its very possible im missing something else.

  • hmm, im getting undefined errors when testing "PWR_REGENERATE_MINERAL" and "PWR_REGENERATE_SOURCE", the other constants like "PWR_GENERATE_OPS" gives "1" as expected?

    ReferenceError: PWR_REGENERATE_SOURCE is not defined at eval (eval at (_console1552235402452_0:1:46), :1:1) at _console1552235402452_0:1:46 at _console1552235402452_0:1:60 at Object.exports.evalCode (:15723:71) at (:17197:41)

  • @geir1983 they changed it to PWR_REGEN_MINERAL etc i think

  • @slowmotionghost thanks, those constants worked. The ptr docs is not updated so i used what was in there, i was hoping it was related somehow to my issue of spawning the powerCreeps, but seems unrelated. Im still not able to spawn them in. Passing a different structure gives the appropriate error code.

  • Dev Team

    CLI is fixed in v3.3.0-beta.4.