Issues Setting up Git

  • Hello, I am playing in shard 3 if that affects this.

    Issue: I have connected my github account, and approved the email only access that screeps requests. Once I refresh the page I can see my user name for github and it is correct. I click the sync repo underneath it, which says not selected, it highlights, and then returns to normal.

    What should happen: After looking at the webpage in inspect it looks like clicking this spot should bring up a window or something that would allow me to select which of my github repos i want to use.

    Notes: Repo is private. I tried setting to public same result. i tried to make a new repo that started as public, same result.

  • There are many instances, both in forums and public alliance chats here, acknowledging the issue as something they are aware of and working on.

    Not to dissuade your post. Just wanted to let you know people are aware of it and it is being worked on last I heard.


  • @wykrmn said in Issues Setting up Git:

    t wanted to let you know people

    Thank you~, the only posts i was seeing about git where from years ago. I am glad it is not something i messed up.

  • This is most likely due to Github changing what authentication methods are allowed to be used for 3rd party apps when connecting to a repository.

    You will notice the following error produced when clicking the "Sync from repository" button:

    error: "{"message":"Must specify access token via Authorization header.","documentation_url":""}"

    This will need to be fixed on the Devs end