npx creeps start failed -> code E404 - 404 Not FOund: creeps@latest

  • Hi, i tried to start private server:

    npm install isolated-vm # vm first to solve a bug during install
    npm install screeps # install screeps
    npx screeps init # init screeps

    npm install screepsmod-auth # install auth
    npm screeps install # reinstall screeps, because the screepsmod-auth will deinstall shit

    D:\Projekte\screeps\server> npx creeeps start
    npm ERR! code E404
    npm ERR! 404 Not Found: creeeps@latest

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\user\AppData\Roaming\npm-cache_logs\2019-11-16T12_43_41_264Z-debug.log
    Install for creeeps@latest failed with code 1


    0 info it worked if it ends with ok
    1 verbose cli [ 'C:\Program Files\nodejs\node.exe',
    1 verbose cli 'C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js',
    1 verbose cli 'install',
    1 verbose cli 'creeeps@latest',
    1 verbose cli '--global',
    1 verbose cli '--prefix',
    1 verbose cli 'C:\Users\user\AppData\Roaming\npm-cache\_npx\13276',
    1 verbose cli '--loglevel',
    1 verbose cli 'error',
    1 verbose cli '--json' ]
    2 info using npm@6.4.1
    3 info using node@v10.15.3
    4 verbose npm-session 0ff75b533afd38aa
    5 silly install loadCurrentTree
    6 silly install readGlobalPackageData
    7 http fetch GET 404 895ms
    8 silly fetchPackageMetaData error for creeeps@latest 404 Not Found: creeeps@latest
    9 timing stage:rollbackFailedOptional Completed in 0ms
    10 timing stage:runTopLevelLifecycles Completed in 1170ms
    11 verbose stack Error: 404 Not Found: creeeps@latest
    11 verbose stack at fetch.then.res (C:\Program Files\nodejs\node_modules\npm\node_modules\pacote\lib\fetchers
    \registry\fetch.js:42:19) 11 verbose stack at tryCatcher (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release
    \util.js:16:23) 11 verbose stack at Promise._settlePromiseFromHandler (C:\Program Files\nodejs\node_modules
    11 verbose stack at Promise._settlePromise (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird
    11 verbose stack at Promise._settlePromise0 (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:614:10)
    11 verbose stack at Promise._settlePromises (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:693:18)
    11 verbose stack at Async._drainQueue (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:133:16)
    11 verbose stack at Async._drainQueues (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:143:10)
    11 verbose stack at Immediate.Async.drainQueues [as _onImmediate] (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:17:14)
    11 verbose stack at runCallback (timers.js:705:18)
    11 verbose stack at tryOnImmediate (timers.js:676:5)
    11 verbose stack at processImmediate (timers.js:658:5)
    12 verbose cwd D:\Projekte\screeps\server
    13 verbose Windows_NT 10.0.17134
    14 verbose argv "C:\Program Files\nodejs\node.exe" "C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "install" "creeeps@latest" "--global" "--prefix" "C:\Users\user\AppData\Roaming\npm-cache\_npx\13276" "--loglevel" "error" "--json"
    15 verbose node v10.15.3
    16 verbose npm v6.4.1
    17 error code E404
    18 error 404 Not Found: creeeps@latest
    19 verbose exit [ 1, true ]

    did i something wrong ?

  • @chuckingame said in npx creeps start failed -> code E404 - 404 Not FOund: creeps@latest:

    npx creeeps start

    Looks like a minor typo - try "screeps" instead of "creeeps".


  • @jbyoshi thanks, you are right 🙂 .... why for hell i haven't seen that myself.....